Edstortion Rack 3 Mode Distortion

  • Sale
  • Regular price $99.00


Release Version 1.0.2

DOWNLOAD MANUAL RACK

Like the original acclaimed Eddie Kramer Edstortion Pedal by F-Pedals, the plug-in, features 3 modes of classic distortion based on the legendary work of Eddie Kramer with Jimi Hendrix, Led Zeppelin, Rolling Stones, The Beatles, Traffic and so many more.
The Plug-in comes in two different versions, one in the shape and sound of the original pedal and one totally new, in a rack version packed with extra features and a sonic concept to serve primarily music producers and engineers .
With just a few knobs tweaks you will be transported into the classic tones of the Golden Age of Rock .

Edstortion is a phenomenal tool with an attitude to rock that allows you to achieve an incredibly wide spectrum of tones from heavy compressed distortion to very subtle crunch with great dynamic. 
Those classic tones will add amazing presence, space, flavor and vibe to any production in any style of music from Rock to Hip-hop and dance! 

The Edstortion Rack Plugin, is the perfect complement for any modern musician and producer looking for the ultimate vintage feel to add to their productions.

Edstortion Rack features:

  • Independent controls for left and right channels with individual and global links
  • Dry/Wet: Blends the effected and dry signal.
  • Mid/Side: Activates MID/SIDE encoder/decoder
  • Spread: Great for spreading the stereo image
  • Analog Link: Adds classic vintage vibe by offsetting the 2 channels
  • Phase Reverse: Rotate of 180º the wet signal phase of both channels
  • INPUT/OUTPUT: Level knobs for maximum versatility

    SYSTEM REQUIREMENTS

    • An Intel Pentium 4 compatible CPU
    • 1GB RAM
    • Mac OS 10.9 or newer (Mac users)
    • Windows 7 or newer (PC users)
    • A display resolution of 1280x1024 pixels or more
    • A VST2, VST3, AAX or AudioUnits compatible host
    • iLok authorization onto iLok2, iLok3, Host Computer or iLok cloud. Latest iLok drivers are recommended. iLok Cloud support requires v6.5 or later, www.ilok.com for more info.